loader

Pada tutorial kali ini GemarOprek akan membahas bagaimana membuat Lab OSPF pada topologi jaringan dengan 3 router Mikrotik. pada tutorial ini akan menjelaskan beberapa fitur OSPF serta implementasi praktis dan singkat OSPF pada router Mikrotik.

Definisi OSPF

Open Shortest Path First atau disingkat OSPF adalah sebuah protokol routing otomatis (Dynamic Routing) yang mampu menjaga, mengatur dan mendistribusikan informasi routing antar network mengikuti setiap perubahan jaringan secara dinamis. Pada OSPF dikenal sebuah istilah Autonomus System (AS) yaitu sebuah gabungan dari beberapa jaringan yang sifatnya routing dan memiliki kesamaan metode serta policy pengaturan network, yang semuanya dapat dikendalikan oleh network administrator. Dan memang kebanyakan fitur ini diguakan untuk management dalam skala jaringan yang sangat besar. Oleh karena itu untuk mempermudah penambahan informasi routing dan meminimalisir kesalahan distribusi informasi routing, maka OSPF bisa menjadi sebuah solusi.

OSPF termasuk di dalam kategori IGP (Interior Gateway Protocol) yang memiliki kemampuan Link-State dan Alogaritma Djikstra yang jauh lebih efisien dibandingkan protokol IGP yang lain. Dalam operasinya OSPF menggunakan protokol sendiri yaitu protokol 89.

OSPF ini adalah protokol routing status link yang mendukung variabel panjang subnetmask (VLSM), manual peringkasan rute, otentikasi, dan lain-lain. Ini memiliki jarak administratif standar 110 dan menggunakan biaya untuk menentukan jalur terpendek ke jaringan tujuan. Tidak seperti protokol routing internal lainnya, ospf menyimpan semua rute yang mungkin ke jaringan tujuan. Inilah sebabnya mengapa ospf adalah prosesor-intensif. Kita gambarkan dulu topologi jaringan di bawah ini:

Lab OSPF pada topologi jaringan dengan 3 router Mikrotik

LAB Objective

Tujuan dari LAB Objective ini adalah untuk berhasil menerapkan OSPF pada topologi jaringan yang ditampilkan pada gambar di atas untuk menyediakan konektivitas penuh sehingga setiap tabel routing router diperbarui dengan rute OSPF ke semua tujuan yang tersedia.

Konfigurasi OSPF pada router Mikrotik

Di router 1:

/ip address
add interface=ether1 address=192.168.0.1/30 comment=koneksi_ke_router2"
add interface=ether2 address=192.168.1.1/28 comment="LAN"

Di router 2:

/ip address
add interface=ether1 address=192.168.0.2/30 comment="koneksi_ke_router1"
add interface=ether2 address=192.168.0.5/30 comment="koneksi_ke_router3"
add interface=ether3 address=192.168.1.17/28 comment="koneksi_ke_LAN"

Di router 3:

/ip address
add interface=ether1 address=192.168.0.6/30 comment="koneksi_ke_router2"
add interface=ether2 address=192.168.1.33/28 comment="LAN"

Langkah selanjutnya adalah membuat antarmuka loopback (jembatan). Ini berfungsi untuk emastikan stabilitas OSPF karena antarmuka loopback selalu aktif. Kita membuat jembatan di ketiga router. Lihat di bawah:

Di router 1:

/interface bridge
add name=loopback comment="OSPF loopback"

Di router 2:

/interface bridge
add name=loopback comment="OSPF loopback"

Di router 3:

/interface bridge
add name=loopback comment="OSPF loopback"

Di router 1:

/ip address
add interface=loopback address=172.16.16.1

Di router 2:

/ip address
add interface=loopback address=172.16.16.2

Di router 3:

/ip address
add interface=loopback address=172.16.16.3

Selanjutnya, kita konfigurasi instance OSPF pada ketiga router.

OSPF instance configuration

Di sini, kita akan konfigurasi alamat IP loopback yang ditetapkan pada langkah sebelumnya sebagai ID router ospf. Lihat perintah di bawah:

Di router 1:

/routing ospf instance
set default router-id=172.16.16.1

Di router 2:

/routing ospf instance
set default router-id=172.16.16.2

Di router 3:

/routing ospf instance
set default router-id=172.16.16.3

OSPF network advertisement
Setelah instance ospf terbentuk, kita akan mengiklankan jaringan yang terhubung. Lihat perintah di bawah:

Di router 1:

/routing ospf network
add network=172.16.16.1 area=backbone comment=Loopback
add network=192.168.0.0/30 area=backbone comment="koneksi_ke_router2"
add network=192.168.1.0/28 area=backbone comment="LAN"

Di router 2:

/routing ospf network
add network=172.16.16.2 area=backbone comment=Loopback
add network=192.168.0.0/30 area=backbone comment="koneksi_ke_router1"
add network=192.168.0.4/30 area=backbone comment="koneksi_ke_router3"
add network=192.168.1.16/28 area=backbone comment="LAN"

Di router 3:

/routing ospf network
add network=172.16.16.3 area=backbone comment=Loopback
add network=192.168.0.4/30 area=backbone comment="koneksi_ke_router2"
add network=192.168.1.32/28 area=backbone comment="LAN"

Verification

Untuk memastikan apakah konfigurasi ospf berfungsi dengan baik, kita bisa menggunakan perintah berikut:

/routing ospf neighbor print

Perintah di atas menunjukkan bahwa router lokal telah membentuk hubungan tetangga dengan ospf. Perintah selanjutnya adalah perintah yang menampilkan rute yang dipelajari melalui ospf. Lihat kode di bawah ini:

/routing ospf route print

Setup ip address on client

Jika anda menggunakan GNS3, silahkan konfigurasi PC client anda menggunakan perintah (dalam tutorial ini kami mencoba pada PC1)

PC1> ip 192.168.1.2/28 192.168.1.1

periksa hasil konfigurasi ip anda pada pc client dengan cara

show ip all

Verification on the client

silahkan coba ping ke ip router ataupun ip OSPF yang telah anda konfigurasi, contoh dari PC1 ping ke router 3

PC1> ping 172.16.16.3
84 bytes from 172.16.16.3 icmp_seq=1 ttl=62 time=46.402 ms
84 bytes from 172.16.16.3 icmp_seq=2 ttl=62 time=3.105 ms
84 bytes from 172.16.16.3 icmp_seq=3 ttl=62 time=2.602 ms

lakukan pemeriksaan dengan ping ke ip address lainnya yang sudah anda konfig. jika responnya reply berarti anda sudah ganteng dan memahami konsep sederhana yang telah anda buat 🙂

Jika artikel ini bermanfaat silahkan share atau berlangganan ke blog ini untuk menerima postingan terbaru yang akan di kirim melalui email dan apabila ingin disebarluaskan harap mencantumkan link sumbernya.

Salam Hangat

Sekilas tentang penulis, mimin ArieL FX

Seorang Kuli Server & Datacenter, Terkadang Mendadak menjadi "cowok bayaran". Hanya seorang pengembara dilayar "hitam". Contact: Twitter and Facebook

Leave a Reply

Your email address will not be published. Required fields are marked *

seventeen + ten =